Ad Radar
Facebook Click here to find out more!

Fast Idle on Edlebrock 600, Elect choke

  
Mopar Muscle
Item Posts    Sort Order

Fast Idle on Edlebrock 600, Elect choke

 
DRN Cuda DRN Cuda
New User | Posts: 12 | Joined: 06/12
Posted: 01/13/13
01:32 PM

Hello, I just put a new Eddie 600 on my 1972 318. It has an electric choke. When I start the engine, the idle speed drops off the fast idle cam as soon as I hit the accelerator. The choke is working as far as opening the choke plate is concerned but I can't get it to fast idle. This is actually the second carb, I took back the first one with the same problem so I'm guessing I'm doing something wrong. Any ideas?  

waynep71222 waynep71222
User | Posts: 246 | Joined: 04/12
Posted: 01/14/13
01:45 AM

where did you hook the electric choke coil to???

what source of power...

the positive ignition... or some other location...

how long does it take the choke to open...

do you have both manuals with the carb... the installation manual is about a dozen pages.. but then there is the tuning manual of about 30 or 40 pages..

both are available on the edelbrock site..

post your exact carb number...  

DRN Cuda DRN Cuda
New User | Posts: 12 | Joined: 06/12
Posted: 01/14/13
05:06 PM

The carb is a 1406. I tapped into the radio power line to get power and grounded it to the carb body per the instructions. The choke takes about 8-10 minutes to open completely I didn't time it but it seemed like a long time. I have it adjusted pretty rich but it still kicks off fast idle when cold. Yes, I have both manuals.